来自 金沙澳门官网网址 2019-12-19 15:01 的文章
当前位置: 金沙澳门官网网址 > 金沙澳门官网网址 > 正文

什么样让外网顾客寻常访问内网服务,CCNP之NAT中

图片 1

     NAT技术本身并不难理解,其主要的作用是私网地址和公网地址的转换。但是,在NAT的学习过程中,很容易把NAT的四个地址混淆,并且不知道他们运用的场合。本文就四个地址以及运用的场合进行详细分析。这是一个令多人困惑的问题,如果看了这篇文章,你顿时觉得醍醐灌顶,那还不赶紧打赏。

网络拓扑如下:已做设置:1、防火墙R1上已做NAT,lan1所有用户均能正常上网。2、交换机为普通2层交换机,没有划分VLAN,LAN1为用户PC上网,LAN2为服务器,约5台。3、防火墙R2上已做NAT,lan2所有服务器能正常上网。LAN2下的服务器能PING通LAN1中的pc。4、防火墙R1上已做好端口映射,例如:natserver8protocoltcpglobalinterfaceGigabitEthernet0/0/17777inside192.168.1.993389natserver9protocoltcpglobalinterfaceGigabitEthernet0/0/125inside192.168.1.10025等等5、防火墙R1上除默认路由iproute-static0.0.0.00.0.0.01.1.1.2外新增了一条静态路由:iproute-static192.168.1.0255.255.255.0192.168.0.249:问题如下:1、LAN2中的服务器能PING通LAN1中的PC,但LAN1中的PC不能PING通LAN2中的服务器。是否是我静态路由设置有问题?2、如何让外网用户正常访问LAN2中的服务?3、R1为华为USG2205.R2为华为USG5310.请各位老师、大神不吝赐教,谢谢!

1:NAT产生原因

   众所周知,如果希望自己的电脑可以上网,必须要到运营商(ISP)申请一个账号,这个账号就是你电脑连接上网的公网IP,是全球唯一的。(请注意:事实上,这个公网IP地址是运营商租给你的,当用户不租的时候,ISP会将此IP地址收回,并租给其他用户)。只有申请到了公网IP才可以连接到Internet.但是,IP地址只有32位,全球那么多电脑要上网,并且只能一台主机一个公网IP,显然,IP地址是不够的。对此,从长远的角度,提出了IPV6的解决方案。但是,在IPV4到IPV6的过度期间,必须存在一种技术解决地址短缺的问题,于是出现了NAT技术。

2:NAT作用

NAT完成私有地址和公有地址的转换。

3:NAT应用场合

NAT技术最常用的两种场景是:

第一种:内部网络用户使用私网地址上网

第二种:用户通过公共网络访问内部网络中的设备(例如:服务器)

4:NAT四种地址以及区别

图片 2

内部本地地址:转换之前内部源地址的地址

内部全局地址:转换之后内部主机的地址

外部本地地址:转换之前目标主机的地址

外部全局地址:转换之后外部目标主机的地址

5:NAT两种适用场合的实验模拟

5.1NAT常用的第一种场合:当内部网络用户通过私用网络上网

请注意本实验中用路由器来模拟PC和Sever

图片 3

实验配置如下:

PC1的配置为:

PC1#conf t

PC1#no ip routing

PC1#ip default-gateway 192.168.0.1

PC1#int f0/0

PC1#no shu

PC1#ip add 192.168.0.10 255.255.255.0

PC1#no shu

PC1#exit

Sever的配置为:

Sever#conf t

Sever #no ip routing

Sever #ip default-gateway 192.168.0.1

Sever #int f0/0

Sever #no shu

Sever #ip add 192.168.0.20 255.255.255.0

Sever #no shu

Sever #exit

对R1的配置为:

R1(config)#int f0/0

R1(config-if)#no shu

R1(config-if)#ip add 192.168.0.1 255.255.255.0///这里IP地址与PC,Sever的网关地址相同

R1(config-if)#ip nat inside

R1(config-if)#exit

R1(config)#int s1/0

R1(config-if)#no shu

R1(config-if)#ip add 200.10.10.1 255.255.255.0

R1(config-if)#ip nat outside

R1(config-if)#no shu

R1(config-if)#exit

R1(config)#ip nat inside source static 192.168.0.10 200.10.10.30

R1(config)#router ospf 1

R1(config-router)#network 200.10.10.0 0.0.0.255 a

R1(config-router)#network 200.10.10.0 0.0.0.255 area 0

对R2的配置为:

R2#conf t

R2(config)#int s1/0

R2(config-if)#no shu

R2(config-if)#ip add 200.10.10.2 255.255.255.0

R2(config-if)#exit

R2(config)#int e0/1

R2(config-if)#no shu

R2(config-if)#ip add 100.20.20.1 255.255.255.0

R2(config)#router ospf 1

R2(config-router)#network 200.10.10.0 0.0.0.255 area 0

R2(config-router)#network 100.20.20.0 0.0.0.255 area 0

R2(config-router)#exit

本文由金沙澳门官网网址发布于金沙澳门官网网址,转载请注明出处:什么样让外网顾客寻常访问内网服务,CCNP之NAT中

关键词: