来自 电脑系统 2019-09-14 02:58 的文章
当前位置: 金沙澳门官网网址 > 电脑系统 > 正文

安装和使用,系统升级更新

ERROR: While executing gem ... (Errno::EPERM)

删除源 $ sudo gem sources -r 

安装最后一步:

$ sudo gem install cocoa pods

$ sudo gem install cocoapods

终端会出错:

$ pod setup

在终端的前面几个步骤就此省略,详细可参见:CocoaPods安装和使用教程

删除Cocoapods $ gem uninstall cocoapods

Operation not permitted - /usr/bin/xcodeproj

$ sudo gem update --system

将其改成等待几秒即可:

$ sudo gem install -n /usr/local/bin cocoapods

在项目文件夹下创建默认的 Podfile $ pod init

$ gem sources -a

更新包 $ sudo gem update

打开Podfile,在第一行写下platform :ios, '8.0',指定平台以及所支持的版本。

$ sudo gem install -n /usr/local/bin cocoapods

3、修改gem源:gem sources -a https://gems.ruby-china.org

查看gem源 $ gem sources –l

$ pod setup

6.更新 gem

更新 $ pod update

$ pod search 第三方

2、删除gem源:gem sources --remove https://ruby.taobao.org/

5、升级cocoapods:sudo gem install -n /usr/local/bin cocoapods --pre

第一次使用安装框架 $ pod install

7.新建工程,并在终端用 cd 指令到文件夹内

添加源 $ sudo gem sources -a 

1.首先打开launch,找到工具文件夹中的终端,打开 终端

列出本地安装的包 $ gem list

gem自身升级 $ sudo gem update --system

清除过期的gem $ sudo gem cleanup

$ gem sources -l

本文由金沙澳门官网网址发布于电脑系统,转载请注明出处:安装和使用,系统升级更新

关键词: